Advanced Unified MPLS


Configuration steps
Configure NTTN IP addressing, IGP,BGP, MPLS, Unified MPLS
Configure ISPs IP addressing, IGP,BGP, MPLS
Configure NTTN’S clients

Configure ISP’s clients

Configure Inter AS MPLS Option A,B,C

R1-P1-RR1

en

conf t

hostname R1-P1-RR1

ip cef

mpls ip

int f2/0

no shut

ip address 10.10.12.1 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f2/1

no shut

ip address 10.10.15.1 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/0

no shut

ip address 10.10.13.1 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/1

no shut

ip address 10.10.14.1 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int lo 0

ip address 10.100.103.1 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

router-id 10.100.103.1

!

mpls ldp router-id lo 0

!

end

wr

 

 

R2-P2-RR2

en

conf t

hostname R2-P2-RR2

ip cef

mpls ip

 

int f2/0

no shut

ip address 10.10.12.2 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f2/1

no shut

ip address 10.10.27.2 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/0

no shut

ip address 10.10.24.2 255.255.255.0

ip ospf 10 area 0

mpls ip

!

 

int lo 0

ip address 10.100.103.2 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

router-id 10.100.103.2

!

mpls ldp router-id lo 0

!

end

wr

 

 

R3-P3

en

conf t

hostname R3-P3

ip cef

mpls ip

 

int f2/0

no shut

ip address 10.10.34.3 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f2/1

no shut

ip address 10.10.36.3 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/0

no shut

ip address 10.10.13.3 255.255.255.0

ip ospf 10 area 0

mpls ip

!

 

int lo 0

ip address 10.100.103.3 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

router-id 10.100.103.3

!

mpls ldp router-id lo 0

!

end

wr

 

R4-P4

conf t

hostname R4-P4

ip cef

mpls ip

 

int f2/0

no shut

ip address 10.10.34.4 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f2/1

no shut

ip address 10.10.48.4 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/0

no shut

ip address 10.10.24.4 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/1

no shut

ip address 10.10.14.4 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int lo 0

ip address 10.100.103.4 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

router-id 10.100.103.4

!

mpls ldp router-id lo 0

!

end

wr

 

 

R5-ASBR-1-NZRR

conf t

hostname R5-ASBR-1-NZRR

ip cef

mpls ip

 

int f2/0

no shut

ip address 10.10.115.5 255.255.255.0

ip ospf 20 area 0

mpls ip

!

int f2/1

no shut

ip address 10.10.15.5 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/0

no shut

ip address 10.10.56.5 255.255.255.0

ip ospf 20 area 0

mpls ip

!

 

int lo 1

ip address 10.100.101.5 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

!

router ospf 20

!

end

wr

 

 

 

R6-ASBR-2

conf t

hostname R6-ASBR-2

ip cef

mpls ip

 

int f2/0

no shut

ip address 10.10.126.6 255.255.255.0

ip ospf 20 area 0

mpls ip

!

int f2/1

no shut

ip address 10.10.36.6 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/0

no shut

ip address 10.10.56.6 255.255.255.0

ip ospf 20 area 0

mpls ip

!

int f4/0

no shut

ip address 10.10.116.6 255.255.255.0

ip ospf 20 area 0

mpls ip

!

int lo 1

ip address 10.100.101.6 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

!

router ospf 20

!

 

end

wr

 

 

R7-ASBR-3-SZRR

conf t

hostname R7-ASBR-3-SZRR

ip cef

mpls ip

 

int f2/0

no shut

ip address 10.10.79.7 255.255.255.0

ip ospf 30 area 0

mpls ip

!

int f2/1

no shut

ip address 10.10.27.7 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/0

no shut

ip address 10.10.78.7 255.255.255.0

ip ospf 30 area 0

mpls ip

!

int f4/0

no shut

ip address 10.10.107.7 255.255.255.0

ip ospf 30 area 0

mpls ip

!

 

int lo 1

ip address 10.100.101.7 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

!

router ospf 30

!

 

end

wr

 

 

R8-ASBR-4-SZRR1

conf t

hostname R8-ASBR-4

ip cef

mpls ip

 

int f2/0

no shut

ip address 10.10.108.8 255.255.255.0

ip ospf 30 area 0

mpls ip

!

int f2/1

no shut

ip address 10.10.48.8 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/0

no shut

ip address 10.10.78.8 255.255.255.0

ip ospf 30 area 0

mpls ip

!

 

int lo 1

ip address 10.100.101.8 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

!

router ospf 30

!

 

end

wr

 

 

R-9-Vxr

 

conf t

hostname R-9-Vxr

 

interface GigabitEthernet0/0/0/3

no shut

ipv4 address 10.10.79.9 255.255.255.0

!

interface GigabitEthernet0/0/0/4

no shut

ipv4 address 10.10.109.9 255.255.255.0

!

interface Loopback0

ipv4 address 10.100.103.9 255.255.255.255

!

 

router ospf 30

router-id 10.100.103.9

area 0

mpls ldp auto-config

interface Loopback0

!

interface GigabitEthernet0/0/0/3

!

interface GigabitEthernet0/0/0/4

!

mpls ldp router-id 10.100.103.9

commit

 

 

 

R10-JMx

 

set system host-name R10-JMx

set interfaces ge-0/0/2 unit 0 family inet address 10.10.108.10/24

set interfaces ge-0/0/2 unit 0 family mpls

set interfaces ge-0/0/4 unit 0 family inet address 10.10.109.10/24

set interfaces ge-0/0/4 unit 0 family mpls

set interfaces ge-0/0/5 unit 0 family inet address 10.10.107.10/24

set interfaces ge-0/0/5 unit 0 family mpls

set interfaces lo0 unit 0 family inet address 10.100.103.10/32

set protocols mpls interface ge-0/0/2.0

set protocols mpls interface ge-0/0/4.0

set protocols mpls interface ge-0/0/5.0

set protocols mpls interface lo0.0

set protocols mpls traffic-engineering mpls-forwarding         ***[without this first hop traceroute will not show label]***

 

set protocols ospf area 0.0.0.0 interface ge-0/0/2.0

set protocols ospf area 0.0.0.0 interface ge-0/0/4.0

set protocols ospf area 0.0.0.0 interface ge-0/0/5.0

set protocols ospf area 0.0.0.0 interface lo0.0

 

set protocols ldp interface ge-0/0/2.0

set protocols ldp interface ge-0/0/4.0

set protocols ldp interface ge-0/0/5.0

set protocols ldp interface lo0.0

set routing-options router-id 10.100.103.10

commit

 

 

R11-JMx

 

set system host-name R11-JMx

set interfaces ge-0/0/2 unit 0 family inet address 10.10.115.11/24

set interfaces ge-0/0/2 unit 0 family mpls

set interfaces ge-0/0/4 unit 0 family inet address 10.10.121.11/24

set interfaces ge-0/0/4 unit 0 family mpls

set interfaces ge-0/0/5 unit 0 family inet address 10.10.116.11/24

set interfaces ge-0/0/5 unit 0 family mpls

set interfaces lo0 unit 0 family inet address 10.100.103.11/32

set protocols mpls interface ge-0/0/2.0

set protocols mpls interface ge-0/0/4.0

set protocols mpls interface ge-0/0/5.0

set protocols mpls interface lo0.0

set protocols mpls traffic-engineering mpls-forwarding                 ***[without this first hop traceroute will not show label]***

 

set protocols ospf area 0.0.0.0 interface ge-0/0/2.0

set protocols ospf area 0.0.0.0 interface ge-0/0/4.0

set protocols ospf area 0.0.0.0 interface ge-0/0/5.0

set protocols ospf area 0.0.0.0 interface lo0.0

 

set protocols ldp interface ge-0/0/2.0

set protocols ldp interface ge-0/0/4.0

set protocols ldp interface ge-0/0/5.0

set protocols ldp interface lo0.0

set routing-options router-id 10.100.103.11

commit

 

 

 

R-12-Vxr

 

conf t

hostname R-12-Vxr

 

interface GigabitEthernet0/0/0/3

no shut

ipv4 address 10.10.126.12 255.255.255.0

!

interface GigabitEthernet0/0/0/4

no shut

ipv4 address 10.10.121.12 255.255.255.0

!

interface Loopback0

ipv4 address 10.100.103.12 255.255.255.255

!

 

router ospf 20

router-id 10.100.103.12

area 0

mpls ldp auto-config

interface Loopback0

!

interface GigabitEthernet0/0/0/3

!

interface GigabitEthernet0/0/0/4

!

mpls ldp router-id 10.100.103.12

commit

 

******************************************************************************

 

ASBR OSPF redistribute with filtering

R5-ASBR-1-NZRR

conf t

ip prefix-list LB-10 seq 10 permit 10.100.101.5/32

 

route-map 10-PID-20 permit 10

match ip address prefix-list LB-10

!

 

router ospf 20

redistribute ospf 20 metric-type 1 subnets route-map 10-PID-20

 

end

wr

 

R6-ASBR-2-NZRR1RR1

conf t

ip prefix-list LB-10 seq 20 permit 10.100.101.6/32

 

route-map 10-PID-20 permit 10

match ip address prefix-list LB-10

!

router ospf 20

redistribute ospf 10 metric-type 1 subnets route-map 10-PID-20

 

end

wr

 

 

R7-ASBR-3-SZRR

conf t

ip prefix-list LB-10 seq 70 permit 10.100.101.7/32

 

 

route-map 10-PID-30 permit 10

match ip address prefix-list LB-10

!

 

 

router ospf 30

redistribute ospf 10 metric-type 1 subnets route-map 10-PID-30

end

wr

 

R8-ASBR-4-SZRR1-SZRR1

conf t

ip prefix-list LB-10 seq 80 permit 10.100.101.8/32

 

route-map 10-PID-30 permit 10

match ip address prefix-list LB-10

!

 

router ospf 30

redistribute ospf 10 metric-type 1 subnets route-map 10-PID-30

end

wr

 

Default route push into IGP

**Default route to match any traffic out to the ASBR**

ASBR which connected with Juniper PE, juniper pe needs default route otherwise not working

R5,R6

router ospf 20

default-information originate always metric-type 1

R7,R8

router ospf 30

default-information originate always metric-type 1

 

******************************************************************************

BGP configuration

 

***Important notes

RR to all rr-client next-hop self all, from rr-client to RR no need next-hop self all

Zonal RR to Central RR both end need to confirue next-hop self all its very important

due to RIB failure some router will not entry bgp route in routing table(already this prefixes learned via igp with best path)***

 

 

NZ RR

R5-ASBR-1-NZRR

 

conf t

router bgp 5

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor RRCLIENT peer-group

neighbor RRCLIENT remote-as 5

neighbor RRCLIENT update-source Loopback1

neighbor 10.100.101.6 peer-group RRCLIENT

neighbor 10.100.103.11 peer-group RRCLIENT

neighbor 10.100.103.12 peer-group RRCLIENT

neighbor 10.100.103.1 remote-as 5

neighbor 10.100.103.2 remote-as 5

neighbor 10.100.103.1 update-source Loopback1

neighbor 10.100.103.2 update-source Loopback1

!

address-family ipv4

neighbor RRCLIENT route-reflector-client

neighbor RRCLIENT next-hop-self all

neighbor RRCLIENT send-label

neighbor 10.100.101.6 activate

neighbor 10.100.103.11 activate

neighbor 10.100.103.12 activate

neighbor 10.100.103.1 activate

neighbor 10.100.103.1 send-label

neighbor 10.100.103.2 activate

neighbor 10.100.103.2 send-label

exit-address-family

!

address-family vpnv4

neighbor RRCLIENT send-community extended

neighbor RRCLIENT route-reflector-client

neighbor 10.100.101.6 activate

neighbor 10.100.103.11 activate

neighbor 10.100.103.12 activate

neighbor 10.100.103.1 activate

neighbor 10.100.103.1 send-community extended

neighbor 10.100.103.2 activate

neighbor 10.100.103.1 send-community extended

exit-address-family

do wr

 

 

NZ RR1

R5-ASBR-2-NZRR1

 

conf t

router bgp 5

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor RRCLIENT peer-group

neighbor RRCLIENT remote-as 5

neighbor RRCLIENT update-source Loopback1

neighbor 10.100.101.5 peer-group RRCLIENT

neighbor 10.100.103.11 peer-group RRCLIENT

neighbor 10.100.103.12 peer-group RRCLIENT

neighbor 10.100.103.1 remote-as 5

neighbor 10.100.103.2 remote-as 5

neighbor 10.100.103.1 update-source Loopback1

neighbor 10.100.103.2 update-source Loopback1

!

address-family ipv4

neighbor RRCLIENT route-reflector-client

neighbor RRCLIENT next-hop-self all

neighbor RRCLIENT send-label

neighbor 10.100.101.5 activate

neighbor 10.100.103.11 activate

neighbor 10.100.103.12 activate

neighbor 10.100.103.1 activate

neighbor 10.100.103.1 send-label

neighbor 10.100.103.2 activate

neighbor 10.100.103.2 send-label

exit-address-family

!

address-family vpnv4

neighbor RRCLIENT send-community extended

neighbor RRCLIENT route-reflector-client

neighbor 10.100.101.5 activate

neighbor 10.100.103.11 activate

neighbor 10.100.103.12 activate

neighbor 10.100.103.1 activate

neighbor 10.100.103.1 send-community extended

neighbor 10.100.103.2 activate

neighbor 10.100.103.1 send-community extended

exit-address-family

do wr

 

 

Central RR configuration

R1-P1-RR1

 

conf t

router bgp 5

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor RRCLIENT peer-group

neighbor RRCLIENT remote-as 5

neighbor RRCLIENT update-source Loopback0

neighbor 10.100.103.2 peer-group RRCLIENT

neighbor 10.100.103.3 peer-group RRCLIENT

neighbor 10.100.103.4 peer-group RRCLIENT

neighbor 10.100.101.5 peer-group RRCLIENT

neighbor 10.100.101.6 peer-group RRCLIENT

neighbor 10.100.101.7 peer-group RRCLIENT

neighbor 10.100.101.8 peer-group RRCLIENT

 

!

address-family ipv4

neighbor RRCLIENT route-reflector-client

neighbor RRCLIENT next-hop-self all

neighbor RRCLIENT send-label

neighbor 10.100.103.2 activate

neighbor 10.100.103.3 activate

neighbor 10.100.103.4 activate

neighbor 10.100.101.5 activate

neighbor 10.100.101.6 activate

neighbor 10.100.101.7 activate

neighbor 10.100.101.8 activate

exit-address-family

!

address-family vpnv4

neighbor RRCLIENT send-community extended

neighbor RRCLIENT route-reflector-client

neighbor 10.100.103.2 activate

neighbor 10.100.103.3 activate

neighbor 10.100.103.4 activate

neighbor 10.100.101.5 activate

neighbor 10.100.101.6 activate

neighbor 10.100.101.7 activate

neighbor 10.100.101.8 activate

exit-address-family

do wr

 

R2-P2-RR2

 

conf t

router bgp 5

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor RRCLIENT peer-group

neighbor RRCLIENT remote-as 5

neighbor RRCLIENT update-source Loopback0

neighbor 10.100.103.1 peer-group RRCLIENT

neighbor 10.100.103.3 peer-group RRCLIENT

neighbor 10.100.103.4 peer-group RRCLIENT

neighbor 10.100.101.5 peer-group RRCLIENT

neighbor 10.100.101.6 peer-group RRCLIENT

neighbor 10.100.101.7 peer-group RRCLIENT

neighbor 10.100.101.8 peer-group RRCLIENT

 

!

address-family ipv4

neighbor RRCLIENT route-reflector-client

neighbor RRCLIENT next-hop-self all

neighbor RRCLIENT send-label

neighbor 10.100.103.1 activate

neighbor 10.100.103.3 activate

neighbor 10.100.103.4 activate

neighbor 10.100.101.5 activate

neighbor 10.100.101.6 activate

neighbor 10.100.101.7 activate

neighbor 10.100.101.8 activate

exit-address-family

!

address-family vpnv4

neighbor RRCLIENT send-community extended

neighbor RRCLIENT route-reflector-client

neighbor 10.100.103.1 activate

neighbor 10.100.103.3 activate

neighbor 10.100.103.4 activate

neighbor 10.100.101.5 activate

neighbor 10.100.101.6 activate

neighbor 10.100.101.7 activate

neighbor 10.100.101.8 activate

exit-address-family

do wr

 

 

SZ RR

R7-ASBR-3-SZRR

 

conf t

router bgp 5

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor RRCLIENT peer-group

neighbor RRCLIENT remote-as 5

neighbor RRCLIENT update-source Loopback1

neighbor 10.100.101.8 peer-group RRCLIENT

neighbor 10.100.103.9 peer-group RRCLIENT

neighbor 10.100.103.10 peer-group RRCLIENT

neighbor 10.100.103.1 remote-as 5

neighbor 10.100.103.2 remote-as 5

neighbor 10.100.103.1 update-source Loopback1

neighbor 10.100.103.2 update-source Loopback1

!

address-family ipv4

neighbor RRCLIENT route-reflector-client

neighbor RRCLIENT next-hop-self all

neighbor RRCLIENT send-label

neighbor 10.100.101.8 activate

neighbor 10.100.103.9 activate

neighbor 10.100.103.10 activate

neighbor 10.100.103.1 activate

neighbor 10.100.103.1 send-label

neighbor 10.100.103.2 activate

neighbor 10.100.103.2 send-label

exit-address-family

!

address-family vpnv4

neighbor RRCLIENT send-community extended

neighbor RRCLIENT route-reflector-client

neighbor 10.100.101.8 activate

neighbor 10.100.103.9 activate

neighbor 10.100.103.10 activate

neighbor 10.100.103.1 activate

neighbor 10.100.103.1 send-community extended

neighbor 10.100.103.2 activate

neighbor 10.100.103.1 send-community extended

exit-address-family

do wr

 

 

SZ RR1

R8-ASBR-4-SZRR1

 

conf t

router bgp 5

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor RRCLIENT peer-group

neighbor RRCLIENT remote-as 5

neighbor RRCLIENT update-source Loopback1

neighbor 10.100.101.7 peer-group RRCLIENT

neighbor 10.100.103.9 peer-group RRCLIENT

neighbor 10.100.103.10 peer-group RRCLIENT

neighbor 10.100.103.1 remote-as 5

neighbor 10.100.103.2 remote-as 5

neighbor 10.100.103.1 update-source Loopback1

neighbor 10.100.103.2 update-source Loopback1

!

address-family ipv4

neighbor RRCLIENT route-reflector-client

neighbor RRCLIENT next-hop-self all

neighbor RRCLIENT send-label

neighbor 10.100.101.7 activate

neighbor 10.100.103.9 activate

neighbor 10.100.103.10 activate

neighbor 10.100.103.1 activate

neighbor 10.100.103.1 send-label

neighbor 10.100.103.2 activate

neighbor 10.100.103.2 send-label

exit-address-family

!

address-family vpnv4

neighbor RRCLIENT send-community extended

neighbor RRCLIENT route-reflector-client

neighbor 10.100.101.7 activate

neighbor 10.100.103.9 activate

neighbor 10.100.103.10 activate

neighbor 10.100.103.1 activate

neighbor 10.100.103.1 send-community extended

neighbor 10.100.103.2 activate

neighbor 10.100.103.1 send-community extended

exit-address-family

do wr

 

 

R3-P3, R4-p4

conf t

router bgp 5

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 10.100.103.1 remote-as 5

neighbor 10.100.103.1 update-source Loopback0

neighbor 10.100.103.2 remote-as 5

neighbor 10.100.103.2 update-source Loopback0

!

address-family ipv4

neighbor 10.100.103.1 activate

neighbor 10.100.103.2 activate

exit-address-family

!

do wr

 

R10-JMx

set routing-options autonomous-system 5

set protocols bgp group PE type internal

set protocols bgp group PE local-address 10.100.103.10

set protocols bgp group PE family inet unicast

set protocols bgp group PE family inet labeled-unicast rib inet.3

set protocols bgp group PE family inet-vpn any

set protocols bgp group PE export EXP_LB

set protocols bgp group PE neighbor 10.100.101.7

set protocols bgp group PE neighbor 10.100.101.8

 

set policy-options prefix-list LB 10.100.103.10/32

set policy-options policy-statement EXP_LB term 1 from prefix-list LB

set policy-options policy-statement EXP_LB term 1 then accept

set policy-options policy-statement EXP_LB term 2 then reject

commit

 

 

R11-JMx

set routing-options autonomous-system 5

set protocols bgp group PE type internal

set protocols bgp group PE local-address 10.100.103.11

set protocols bgp group PE family inet unicast

set protocols bgp group PE family inet labeled-unicast rib inet.3

set protocols bgp group PE family inet-vpn any

set protocols bgp group PE export EXP_LB

set protocols bgp group PE neighbor 10.100.101.5

set protocols bgp group PE neighbor 10.100.101.6

 

set policy-options prefix-list LB 10.100.103.11/32

set policy-options policy-statement EXP_LB term 1 from prefix-list LB

set policy-options policy-statement EXP_LB term 1 then accept

set policy-options policy-statement EXP_LB term 2 then reject

commit

 

 

R-12-Vxr

conf t

router bgp 5

address-family ipv4 unicast

network 10.100.103.12/32

allocate-label all

!

address-family vpnv4 unicast

!

neighbor 10.100.101.5

remote-as 5

update-source Loopback0

address-family ipv4 unicast

!

address-family vpnv4 unicast

!

!

neighbor 10.100.101.6

remote-as 5

update-source Loopback0

address-family ipv4 unicast

!

address-family vpnv4 unicast

commit

 

 

 

R-9-Vxr

 

conf t

router bgp 5

address-family ipv4 unicast

network 10.100.103.9/32

allocate-label all

!

address-family vpnv4 unicast

!

neighbor 10.100.101.7

remote-as 5

update-source Loopback0

address-family ipv4 unicast

!

address-family vpnv4 unicast

!

!

neighbor 10.100.101.8

remote-as 5

update-source Loopback0

address-family ipv4 unicast

!

address-family vpnv4 unicast

commit

 

 

ISP MPLS Configuration

ISP BT

 

conf t

hostname R1-BT-ASBR

ip cef

mpls ip

 

int f2/1

no shut

ip address 172.16.12.1 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int lo 0

ip address 10.250.103.1 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

router-id 10.250.103.1

!

mpls ldp router-id lo 0

!

 

 

router bgp 10

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 10.250.103.3 remote-as 10

neighbor 10.250.103.3 update-source Loopback 0

!

address-family ipv4

neighbor 10.250.103.3 route-reflector-client

neighbor 10.250.103.3 next-hop-self

neighbor 10.250.103.3 activate

exit-address-family

!

address-family vpnv4

neighbor 10.250.103.3 send-community extended

neighbor 10.250.103.3 route-reflector-client

neighbor 10.250.103.3 activate

exit-address-family

 

end

wr

 

 

R2-BT-P

 

conf t

hostname R2-BT-P

ip cef

mpls ip

 

int f2/1

no shut

ip address 172.16.12.2 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int f3/0

no shut

ip address 172.16.23.2 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int lo 0

ip address 10.250.103.2 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

router-id 10.250.103.2

!

mpls ldp router-id lo 0

 

end

wr

 

 

R3-BT-PE

 

conf t

hostname R3-BT-PE

ip cef

mpls ip

 

int f3/0

no shut

ip address 172.16.23.3 255.255.255.0

ip ospf 10 area 0

mpls ip

!

int lo 0

ip address 10.250.103.3 255.255.255.255

ip ospf 10 area 0

!

router ospf 10

router-id 10.250.103.3

!

mpls ldp router-id lo 0

!

 

router bgp 10

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 10.250.103.1 remote-as 10

neighbor 10.250.103.1 update-source Loopback 0

!

address-family ipv4

neighbor 10.250.103.1 next-hop-self

neighbor 10.250.103.1 activate

exit-address-family

!

address-family vpnv4

neighbor 10.250.103.1 send-community extended

neighbor 10.250.103.1 activate

exit-address-family

 

end

wr

******************************************************************************

 

ISP AT

 

conf t

hostname R1-AT-ASBR

ip cef

mpls ip

 

int f2/1

no shut

ip address 172.17.12.1 255.255.255.0

ip ospf 20 area 0

mpls ip

!

int lo 0

ip address 10.200.103.1 255.255.255.255

ip ospf 20 area 0

!

router ospf 20

router-id 10.200.103.1

!

mpls ldp router-id lo 0

!

 

 

router bgp 20

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 10.200.103.3 remote-as 20

neighbor 10.200.103.3 update-source Loopback 0

!

address-family ipv4

neighbor 10.200.103.3 route-reflector-client

neighbor 10.200.103.3 next-hop-self

neighbor 10.200.103.3 activate

exit-address-family

!

address-family vpnv4

neighbor 10.200.103.3 send-community extended

neighbor 10.200.103.3 route-reflector-client

neighbor 10.200.103.3 activate

exit-address-family

 

end

wr

 

 

R2-AT-P

 

conf t

hostname R2-AT-P

ip cef

mpls ip

 

int f2/1

no shut

ip address 172.17.12.2 255.255.255.0

ip ospf 20 area 0

mpls ip

!

int f3/0

no shut

ip address 172.17.23.2 255.255.255.0

ip ospf 20 area 0

mpls ip

!

int lo 0

ip address 10.200.103.2 255.255.255.255

ip ospf 20 area 0

!

router ospf 20

router-id 10.200.103.2

!

mpls ldp router-id lo 0

 

end

wr

 

 

R3-AT-PE

 

conf t

hostname R3-AT-PE

ip cef

mpls ip

 

int f3/0

no shut

ip address 172.17.23.3 255.255.255.0

ip ospf 20 area 0

mpls ip

!

int lo 0

ip address 10.200.103.3 255.255.255.255

ip ospf 20 area 0

!

router ospf 20

router-id 10.200.103.3

!

mpls ldp router-id lo 0

!

 

router bgp 20

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 10.200.103.1 remote-as 20

neighbor 10.200.103.1 update-source Loopback 0

!

address-family ipv4

neighbor 10.200.103.1 next-hop-self

neighbor 10.200.103.1 activate

exit-address-family

!

address-family vpnv4

neighbor 10.200.103.1 send-community extended

neighbor 10.200.103.1 activate

exit-address-family

 

end

wr

 

******************************************************************************

 

ISP VZ

 

conf t

hostname R1-VZ-ASBR

ip cef

mpls ip

 

int f2/1

no shut

ip address 172.18.12.1 255.255.255.0

ip ospf 30 area 0

mpls ip

!

int lo 0

ip address 10.252.103.1 255.255.255.255

ip ospf 30 area 0

!

router ospf 30

router-id 10.252.103.1

!

mpls ldp router-id lo 0

!

 

 

router bgp 30

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 10.252.103.3 remote-as 30

neighbor 10.252.103.3 update-source Loopback 0

!

address-family ipv4

neighbor 10.252.103.3 route-reflector-client

neighbor 10.252.103.3 next-hop-self

neighbor 10.252.103.3 activate

exit-address-family

!

address-family vpnv4

neighbor 10.252.103.3 send-community extended

neighbor 10.252.103.3 route-reflector-client

neighbor 10.252.103.3 activate

exit-address-family

 

end

wr

 

 

R2-VZ-P

 

conf t

hostname R2-VZ-P

ip cef

mpls ip

 

int f2/1

no shut

ip address 172.18.12.2 255.255.255.0

ip ospf 30 area 0

mpls ip

!

int f3/0

no shut

ip address 172.18.23.2 255.255.255.0

ip ospf 30 area 0

mpls ip

!

int lo 0

ip address 10.252.103.2 255.255.255.255

ip ospf 30 area 0

!

router ospf 30

router-id 10.252.103.2

!

mpls ldp router-id lo 0

 

end

wr

 

 

R3-VZ-PE

 

conf t

hostname R3-VZ-PE

ip cef

mpls ip

 

int f3/0

no shut

ip address 172.18.23.3 255.255.255.0

ip ospf 30 area 0

mpls ip

!

int lo 0

ip address 10.252.103.3 255.255.255.255

ip ospf 30 area 0

!

router ospf 30

router-id 10.252.103.3

!

mpls ldp router-id lo 0

!

 

router bgp 30

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 10.252.103.1 remote-as 30

neighbor 10.252.103.1 update-source Loopback 0

!

address-family ipv4

neighbor 10.252.103.1 next-hop-self

neighbor 10.252.103.1 activate

exit-address-family

!

address-family vpnv4

neighbor 10.252.103.1 send-community extended

neighbor 10.252.103.1 activate

exit-address-family

 

end

wr

 

******************************************************************************

 

ISP CZ

 

conf t

hostname R1-CZ-ASBR

ip cef

mpls ip

 

int f2/1

no shut

ip address 172.19.12.1 255.255.255.0

ip ospf 40 area 0

mpls ip

!

int lo 0

ip address 10.253.103.1 255.255.255.255

ip ospf 40 area 0

!

router ospf 40

router-id 10.253.103.1

!

mpls ldp router-id lo 0

 

router bgp 40

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 10.253.103.3 remote-as 40

neighbor 10.253.103.3 update-source Loopback 0

!

address-family ipv4

neighbor 10.253.103.3 route-reflector-client

neighbor 10.253.103.3 next-hop-self

neighbor 10.253.103.3 activate

exit-address-family

!

address-family vpnv4

neighbor 10.253.103.3 send-community extended

neighbor 10.253.103.3 route-reflector-client

neighbor 10.253.103.3 activate

exit-address-family

 

end

wr

 

 

R2-CZ-P

 

conf t

hostname R2-CZ-P

ip cef

mpls ip

 

int f2/1

no shut

ip address 172.19.12.2 255.255.255.0

ip ospf 40 area 0

mpls ip

!

int f3/0

no shut

ip address 172.19.23.2 255.255.255.0

ip ospf 40 area 0

mpls ip

!

int lo 0

ip address 10.253.103.2 255.255.255.255

ip ospf 40 area 0

!

router ospf 40

router-id 10.253.103.2

!

mpls ldp router-id lo 0

 

end

wr

 

 

R3-CZ-PE

 

conf t

hostname R3-CZ-PE

ip cef

mpls ip

 

int f3/0

no shut

ip address 172.19.23.3 255.255.255.0

ip ospf 40 area 0

mpls ip

!

int lo 0

ip address 10.253.103.3 255.255.255.255

ip ospf 40 area 0

!

router ospf 40

router-id 10.253.103.3

!

mpls ldp router-id lo 0

!

 

router bgp 40

bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 10.253.103.1 remote-as 40

neighbor 10.253.103.1 update-source Loopback 0

!

address-family ipv4

neighbor 10.253.103.1 next-hop-self

neighbor 10.253.103.1 activate

exit-address-family

!

address-family vpnv4

neighbor 10.253.103.1 send-community extended

neighbor 10.253.103.1 activate

exit-address-family

 

end

wr

 

 

******************************************************************************

VPLS cisco XRv

XR1

interface GigabitEthernet0/0/0/0

no shut

ipv4 address 10.10.12.1 255.255.255.0

!

interface Loopback0

ipv4 address 10.100.103.1 255.255.255.255

!

 

router ospf 30

router-id 10.100.103.1

area 0

mpls ldp auto-config

interface Loopback0

!

interface GigabitEthernet0/0/0/0

!

mpls ldp router-id 10.100.103.1

 

router bgp 30

address-family ipv4 unicast

address-family l2vpn vpls-vpws

neighbor-group ibgp-pe

remote-as 30

update-source Loopback0

address-family ipv4 unicast

address-family l2vpn vpls-vpws

signalling ldp disable

exit

exit

 

neighbor 10.100.103.2

use neighbor-group ibgp-pe

exit

 

exit

 

 

l2vpn

autodiscovery bgp

signaling-protocol bgp

mtu mismatch ignore

exit

exit

 

bridge group v123

bridge-domain v123

interface gigabitEthernet 0/0/0/1.123

vfi v123

vpn-id 123

autodiscovery bgp

rd auto

route-target import 30:123

route-target export 30:123

signaling-protocol bgp

ve-id 5

ve-range 11

exit

exit

exit

exit

exit

commit

 

***Now we configure XR2

XR2

interface GigabitEthernet0/0/0/0

no shut

ipv4 address 10.10.12.2 255.255.255.0

!

interface Loopback0

ipv4 address 10.100.103.2 255.255.255.255

!

 

router ospf 30

router-id 10.100.103.1

area 0

mpls ldp auto-config

interface Loopback0

!

interface GigabitEthernet0/0/0/0

!

mpls ldp router-id 10.100.103.2

 

 

router bgp 30

address-family ipv4 unicast

address-family l2vpn vpls-vpws

neighbor-group ibgp-pe

remote-as 30

update-source Loopback0

address-family ipv4 unicast

address-family l2vpn vpls-vpws

signalling ldp disable

exit

exit

 

neighbor 10.100.103.1

use neighbor-group ibgp-pe

exit

 

exit

 

 

l2vpn

autodiscovery bgp

signaling-protocol bgp

mtu mismatch ignore

exit

exit

 

bridge group v123

bridge-domain v123

interface gigabitEthernet 0/0/0/1.123

vfi v123

vpn-id 123

autodiscovery bgp

rd auto

route-target import 30:123

route-target export 30:123

signaling-protocol bgp

ve-id 6

ve-range 11

exit

exit

exit

exit

exit

commit

 

verification commands below

show bgp l2vpn vpls summary

show bgp l2vpn vpls

show l2vpn discovery bridge-domain

show l2vpn bridge-domain autodiscovery bgp

sh l2vpn bridge-domain group customer1

sh l2vpn bridge-domain group customer1 detail

show l2vpn discovery

 

XRv for vpls control plane working fine but forwarding plane not working, If you are simulating on GNS3, it will not work as VPLS is a Platform Dependent  feature and requires the hardware to be programmed. We Verify only control plane.

Verification

RP/0/0/CPU0:ios# show bgp summary

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd

10.100.103.2      0    30      39      40        2    0    0 00:33:18          0

 

RP/0/0/CPU0:ios#show bgp l2vpn vpls summary

Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd

10.100.103.2      0    30      39      40        5    0    0 00:33:11          1

 

 

RP/0/0/CPU0:ios#show mpls forwarding

Label  Label       or ID              Interface                    Switched

—— ———– —————— ———— ————— ————

24000  Pop         10.100.103.2/32    Gi0/0/0/0    10.10.12.2      8135

RP/0/0/CPU0:ios#show l2vpn bridge-domain detail

Bridge group: v123, bridge-domain: v123, id: 0, state: up, ShgId: 0, MSTi: 0

 

RP/0/0/CPU0:ios#show l2vpn bridge-domain bd-name v123 detail

List of VFIs:

VFI v123 (up)

VPN-ID: 123, Auto Discovery: BGP, state is  Provisioned (Service Connected)

Route Distinguisher:  (auto) 10.100.103.1:65535

Import Route Targets:

30:123

Export Route Targets:

30:123

Signaling protocol: BGP

Local VE-ID: 5 ,  Advertised Local VE-ID : 5

VE-Range: 11

PW: neighbor 10.100.103.2, PW ID 123, state is up ( established )

PW class not set, XC ID 0xff000001

Encapsulation MPLS, Auto-discovered (BGP), protocol BGP

Source address 10.100.103.1

PW type VPLS, control word enabled, interworking none

Sequencing not set

MPLS         Local                          Remote

———— —————————— ————————-

Label        24020                          24019

MTU          1500                           1500

Control word enabled                        enabled

PW type      VPLS                           VPLS

VE-ID        5                              6

———— —————————— ————————-

 

VPLS Juniper to Juniper

R-11-JMx

set interfaces ge-0/0/6 flexible-vlan-tagging

set interfaces ge-0/0/6 encapsulation flexible-ethernet-services

set interfaces ge-0/0/6 unit 100 description VRF-B

set interfaces ge-0/0/6 unit 100 encapsulation vlan-vpls

set interfaces ge-0/0/6 unit 100 vlan-id 100

 

set routing-instance SMEC instance-type vpls

set routing-instance SMEC vlan-id 100

set routing-instance SMEC interface ge-0/0/6.100

set routing-instance SMEC route-distinguisher 10.100.103.11:100

set routing-instance SMEC vrf-target target:5:100

set routing-instance SMEC protocols vpls

set routing-instance SMEC protocols vpls site-range 8

set routing-instance SMEC protocols vpls no-tunnel-service

set routing-instance SMEC protocols vpls site SMEC_site site-identifier 2

set routing-instance SMEC protocols vpls site SMEC_site interface ge-0/0/6.100

 

 

R-10-JMx

set interfaces ge-0/0/6 flexible-vlan-tagging

set interfaces ge-0/0/6 encapsulation flexible-ethernet-services

set interfaces ge-0/0/6 unit 100 description VRF-B

set interfaces ge-0/0/6 unit 100 encapsulation vlan-vpls

set interfaces ge-0/0/6 unit 100 vlan-id 100

 

set routing-instance SMEC instance-type vpls

set routing-instance SMEC vlan-id 100

set routing-instance SMEC interface ge-0/0/6.100

set routing-instance SMEC route-distinguisher 10.100.103.10:100

set routing-instance SMEC vrf-target target:5:100

set routing-instance SMEC protocols vpls

set routing-instance SMEC protocols vpls site-range 8

set routing-instance SMEC protocols vpls no-tunnel-service

set routing-instance SMEC protocols vpls site SMEC_site site-identifier 2

set routing-instance SMEC protocols vpls site SMEC_site interface ge-0/0/6.100

 

 

verification

show vpls connections

 

root@R10-JMx# run show vpls connections

Legend for interface status

Up — operational

Dn — down

 

Instance: SMEC

Local site: SMEC_site (3)

connection-site           Type  St     Time last up          # Up trans

2                         rmt   Up     Apr  8 19:19:32 2019           1

Remote PE: 10.100.103.11, Negotiated control-word: No

Incoming label: 262170, Outgoing label: 262147

Local interface: lsi.1048576, Status: Up, Encapsulation: VPLS

Description: Intf – vpls SMEC local site 3 remote site 2

 

 

 

IPL-SMEC1#ping 192.168.1.1 source 192.168.1.2 repeat 10000

Type escape sequence to abort.

Sending 10000, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

Packet sent with a source address of 192.168.1.2

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.

Success rate is 99 percent (244/245), round-trip min/avg/max = 40/85/180 ms

 

 

Cisco XRv VRF create and XR(PE) to CE BGP configuration and verification

R-12-Vxr

 

vrf ENT-CT

address-family ipv4 unicast

import route-target

5:1

!

export route-target

5:1

exit

exit

exit

 

interface GigabitEthernet0/0/0/6

no shutdown

vrf ENT-CT

ipv4 address 10.20.20.1 255.255.255.252

exit

 

route-policy PASS

pass

end-policy

 

router bgp 5

vrf ENT-CT

rd 5:1

address-family ipv4 unicast

!

neighbor 10.20.20.2

remote-as 1

address-family ipv4 unicast

route-policy PASS in

route-policy PASS out

as-override

exit

exit

exit

exit

commit

 

 

ENT-CT-1

 

interface Loopback0

ip address 1.1.1.1 255.255.255.255

 

interface FastEthernet2/0

no shutdown

ip address 10.20.20.2 255.255.255.252

 

router bgp 1

bgp log-neighbor-changes

neighbor 10.20.20.1 remote-as 5

!

address-family ipv4

network 1.1.1.1 mask 255.255.255.255

neighbor 10.20.20.1 activate

exit-address-family

 

end

wr

 

 

 

R-9-Vxr

 

vrf ENT-CT

address-family ipv4 unicast

import route-target

5:1

!

export route-target

5:1

exit

exit

exit

 

interface GigabitEthernet0/0/0/6

no shutdown

vrf ENT-CT

ipv4 address 10.20.20.5 255.255.255.252

exit

 

route-policy PASS

pass

end-policy

 

router bgp 5

vrf ENT-CT

rd 5:1

address-family ipv4 unicast

!

neighbor 10.20.20.6

remote-as 1

address-family ipv4 unicast

route-policy PASS in

route-policy PASS out

as-override

exit

exit

exit

exit

commit

 

ENT-CT

 

interface Loopback0

ip address 2.2.2.2 255.255.255.255

 

interface FastEthernet2/0

no shutdown

ip address 10.20.20.6 255.255.255.252

 

router bgp 1

bgp log-neighbor-changes

neighbor 10.20.20.5 remote-as 5

!

address-family ipv4

network 2.2.2.2 mask 255.255.255.255

neighbor 10.20.20.5 activate

exit-address-family

 

end

wr

 

 

 

 

Verification

 

RP/0/0/CPU0:R-12-Vxr#show route vrf ENT-CT

B    1.1.1.1/32 [20/0] via 10.20.20.2, 00:31:24

B    2.2.2.2/32 [200/0] via 10.100.103.9 (nexthop in vrf default), 00:01:49

C    10.20.20.0/30 is directly connected, 01:33:26, GigabitEthernet0/0/0/6

L    10.20.20.1/32 is directly connected, 01:33:26, GigabitEthernet0/0/0/6

 

 

RP/0/0/CPU0:R-9-Vxr#show route vrf ENT-CT

B    1.1.1.1/32 [200/0] via 10.100.103.12 (nexthop in vrf default), 00:35:13

B    2.2.2.2/32 [20/0] via 10.20.20.6, 00:02:31

C    10.20.20.4/30 is directly connected, 01:06:49, GigabitEthernet0/0/0/6

L    10.20.20.5/32 is directly connected, 01:06:49, GigabitEthernet0/0/0/6

 

ENT-CT-1#show ip route

1.0.0.0/32 is subnetted, 1 subnets

C        1.1.1.1 is directly connected, Loopback0

2.0.0.0/32 is subnetted, 1 subnets

B        2.2.2.2 [20/0] via 10.20.20.1, 00:03:02

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        10.20.20.0/30 is directly connected, FastEthernet2/0

L        10.20.20.2/32 is directly connected, FastEthernet2/0

 

In this unified MPLS  we will found 3 types label.

INTER-AS MPLS option A

o  one logical/physical interface per VRF in the interconnection

o  one PE-CE eBGP/IGP session per VRF between ASBRs

o  IP traffic between ASBRs

o  no need for common RDs/RTs between ASNs

o  2 LSPs and 1 IP path from one PE to the other PE

ISP-BT, NTTN

 

R5-ASBR-1NZRR

 

vrf definition BT-CE1

rd 10.100.101.5:1

address-family ipv4

route-target export 5:2

route-target import 5:2

exit

 

interface FastEthernet3/1

no shut

vrf forwarding BT-CE1

ip address 10.20.20.9 255.255.255.252

 

router bgp 5

address-family ipv4 vrf BT-CE1

neighbor 10.20.20.10 remote-as 100

neighbor 10.20.20.10 activate

neighbor 10.20.20.10 as-override

exit-address-family

end

wr

 

R2-BT-CE1

 

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet3/1

ip address 10.20.20.10 255.255.255.252

no shut

 

router bgp 100

bgp log-neighbor-changes

neighbor 10.20.20.9 remote-as 5

!

address-family ipv4

network 2.2.2.2 mask 255.255.255.255

neighbor 10.20.20.9 activate

exit-address-family

 

end

wr

 

 

R3-BT-PE

 

vrf definition BT-CE

rd 10.250.103.3:1

address-family ipv4

route-target export 10:2

route-target import 10:2

exit

 

interface FastEthernet3/1

no shut

vrf forwarding BT-CE

ip address 172.16.10.1 255.255.255.252

 

router bgp 10

address-family ipv4 vrf BT-CE

neighbor 172.16.10.2 remote-as 100

neighbor 172.16.10.2 activate

neighbor 172.16.10.2 as-override

exit-address-family

end

wr

 

 

R4-BT-CE

 

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet3/1

ip address 172.16.10.2 255.255.255.252

no shut

 

router bgp 100

bgp log-neighbor-changes

neighbor 172.16.10.1 remote-as 10

!

address-family ipv4

network 1.1.1.1 mask 255.255.255.255

neighbor 172.16.10.1 activate

exit-address-family

 

end

wr

 

 

R1-BT-ASBR

 

vrf definition BT-CE

rd 10.250.103.1:1

address-family ipv4

route-target export 10:2

route-target import 10:2

exit

 

interface FastEthernet2/0

no shut

vrf forwarding BT-CE

ip address 10.20.20.14 255.255.255.252

 

router bgp 10

address-family ipv4 vrf BT-CE

neighbor 10.20.20.13 remote-as 5

neighbor 10.20.20.13 activate

exit-address-family

end

wr

 

 

R-9-Vxr

 

vrf BT-CE1

address-family ipv4 unicast

import route-target

5:2

!

export route-target

5:2

exit

exit

exit

 

interface GigabitEthernet0/0/0/2

no shutdown

vrf BT-CE1

ipv4 address 10.20.20.13 255.255.255.252

exit

 

route-policy PASS

pass

end-policy

 

router bgp 5

vrf BT-CE1

rd 5:2

address-family ipv4 unicast

!

neighbor 10.20.20.14

remote-as 10

address-family ipv4 unicast

route-policy PASS in

route-policy PASS out

exit

exit

exit

exit

commit

 

 

 

Verification

 

R4-BT-CE#show ip bgp

Network          Next Hop            Metric LocPrf Weight Path

*>  1.1.1.1/32       0.0.0.0                  0         32768 i

*>  2.2.2.2/32       172.16.10.1                            0 10 5 10 i

R4-BT-CE#ping 2.2.2.2 source 1.1.1.1 re

R4-BT-CE#ping 2.2.2.2 source 1.1.1.1 repeat 100

Type escape sequence to abort.

Sending 100, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

Packet sent with a source address of 1.1.1.1

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Success rate is 100 percent (100/100), round-trip min/avg/max = 88/154/216 ms

 

INTER-AS Option B

o  one physical/logical interface for all VRFs in the interconnection

o  eBGP VPNv4 between ASBRs

o  MPLS traffic between ASBRs

o  common RDs/RTs between ASNs (unless RT rewrite is used)

o  next-hop-self on each ASBR for iBGP

 

 

R6-ASBR-2-1NZRR1

 

vrf definition AT-CE1

rd 10.100.101.6:1

address-family ipv4

route-target export 5:20

route-target import 20:5

exit

 

interface FastEthernet3/1

no shut

vrf forwarding AT-CE1

ip address 10.20.20.17 255.255.255.252

 

router bgp 5

address-family ipv4 vrf AT-CE1

neighbor 10.20.20.18 remote-as 200

neighbor 10.20.20.18 activate

neighbor 10.20.20.18 as-override

exit-address-family

end

wr

 

R1-AT-CE1

 

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet3/1

ip address 10.20.20.18 255.255.255.252

no shut

 

router bgp 200

bgp log-neighbor-changes

neighbor 10.20.20.17 remote-as 5

!

address-family ipv4

network 2.2.2.2 mask 255.255.255.255

neighbor 10.20.20.17 activate

exit-address-family

 

end

wr

 

 

R3-AT-PE

 

vrf definition AT-CE

rd 10.200.103.3:1

address-family ipv4

route-target export 20:5

route-target import 5:20

exit

 

interface FastEthernet3/1

no shut

vrf forwarding AT-CE

ip address 172.17.20.1 255.255.255.252

 

router bgp 20

address-family ipv4 vrf AT-CE

neighbor 172.17.20.2 remote-as 200

neighbor 172.17.20.2 activate

neighbor 172.17.20.2 as-override

exit-address-family

end

wr

 

 

R4-AT-CE

 

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet3/1

ip address 172.17.20.2 255.255.255.252

no shut

 

router bgp 200

bgp log-neighbor-changes

neighbor 172.17.20.1 remote-as 20

!

address-family ipv4

network 1.1.1.1 mask 255.255.255.255

neighbor 172.17.20.1 activate

exit-address-family

 

end

wr

 

 

R1-AT-ASBR

 

interface FastEthernet2/0

no shut

ip address 10.20.20.22 255.255.255.252

mpls bgp forwarding

 

 

router bgp 20

no bgp default route-target filter

neighbor 10.20.20.21 remote-as 5

address-family ipv4

no neighbor 10.20.20.21 activate

exit-address-family

address-family vpnv4

neighbor 10.20.20.21 activate

neighbor 10.20.20.21 send-community extended

neighbor 10.200.103.3 next-hop-self       //its very important//

exit-address-family

end

wr

 

 

R-10-JMx

 

set interfaces ge-0/0/1 unit 0 family inet address 10.20.20.21/30

set interfaces ge-0/0/1 unit 0 family mpls

set protocols mpls interface ge-0/0/1.0

 

set protocols bgp group EBGP-AT type external

set protocols bgp group EBGP-AT family inet-vpn unicast

set protocols bgp group EBGP-AT neighbor 10.20.20.22 peer-as 20

 

//this part only for ibgp//

set policy-options policy-statement EXP_LB term 2 then accept

set policy-options policy-statement EXP_LB term 0 then next-hop self       //its very important//

set policy-options policy-statement EXP_LB term 1 from prefix-list LB

set policy-options policy-statement EXP_LB term 1 then accept      //here can accpet specific but in lab i used all//

commit

 

 

 

Verification

R4-AT-CE#ping 2.2.2.2 source 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

Packet sent with a source address of 1.1.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 108/120/148 ms

 

R1-AT-CE1#traceroute 1.1.1.1 source 2.2.2.2

Type escape sequence to abort.

Tracing the route to 1.1.1.1

VRF info: (vrf in name/id, vrf out name/id)

1 10.20.20.17 40 msec 20 msec 8 msec

2 10.10.56.5 [MPLS: Labels 32/299856 Exp 0] 120 msec 124 msec 120 msec

3 10.10.15.1 [MPLS: Labels 30/299856 Exp 0] 144 msec 112 msec 128 msec

4 10.10.12.2 [MPLS: Labels 31/299856 Exp 0] 136 msec 120 msec 120 msec

5 10.10.27.7 [MPLS: Labels 16/299856 Exp 0] 120 msec 116 msec 128 msec

6  *  *  *

7 10.20.20.22 [MPLS: Label 20 Exp 0] 108 msec 124 msec 100 msec

8 172.17.12.2 [MPLS: Labels 17/19 Exp 0] 128 msec 108 msec 132 msec

9 172.17.20.1 [MPLS: Label 19 Exp 0] 112 msec 104 msec 104 msec

10 172.17.20.2 104 msec 108 msec 104 msec

 

 

 

 

 

 

You may also like...